股票軟件
當前位置:股途網 > 股票公式 > 通達信公式 >
標題

波段王指標公式

  • 應用平臺:Win2003,WinXP,Win2000,Win9X
  • 關鍵詞語:波段,王指標,指標,公式,CLOSE,ColorFFFfff
軟件介紹

  線:MA(CLOSE,21),ColorFFFfff,linethicK2;

  生命線:MA(CLOSE,43),Color00Ffff,linethicK2;

  牛熊分界線:MA(CLOSE,250),Color0000ff,linethicK3;

  TY:=C;

  HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);

  LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);

  A:=REF(C,BARSLAST(HD));

  B:=REF(C,BARSLAST(LD));

  T1:=BARSLAST(HD)

  T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);

  波浪頂:IF(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK1;

  STICKLINE(T1,A,A,9,0),COLORFF00FF;

  波浪底:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK1;

  Var3:=LLV(最高價,240);

  Var4:=100*(收盤價-Var3)/Var3;

  Var5:=(收盤價-LLV(最低價,528))/(HHV(最高價,528)-LLV(最低價,528))*100;

  Var6:=(收盤價-LLV(收盤價,530))/(HHV(收盤價,530)-LLV(收盤價,530))*100;

  Var7:=0;

  Var8:=MA(HHV(收盤價-REF(收盤價,1),0),34)/MA(ABS(收盤價-REF(收盤價,1)),7)*100;

  Var9:=MA(HHV(收盤價-REF(收盤價,1),0),13)/MA(ABS(收盤價-REF(收盤價,1)),13)*100;

  VarA:=BARSCOUNT(收盤價);

  VarB:=Var8<20 AND Var9<23 AND VarA>35;

  VarC:=VarB AND COUNT(VarB,1)=1;

  VarD:=EMA(收盤價,21)-EMA(收盤價,8);

  VarE:=EMA(VarD,5);

  VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);

  Var10:=IF(TROUGH(3,16,1)=0 AND 最高價>最低價+0.04,4,0);

  Var11:=ZIG(3,6)>REF(ZIG(3,6),1)

  AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2)

  AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

  Var12:=ZIG(3,6)

  AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2)

  AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

  Var13:=ZIG(3,22)>REF(ZIG(3,22),1)

  AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)

  AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

  Var14:=ZIG(3,22)

  AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)

  AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

  Var15:=ZIG(3,51)>REF(ZIG(3,51),1)

  AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2)

  AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

  Var16:=ZIG(3,51)

  AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)

  AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

  Var17:=ZIG(3,72)>REF(ZIG(3,72),1)

  AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)

  AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

  Var18:=ZIG(3,72)

  AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)

  AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

  Var19:=EMA(收盤價,2)-EMA(收盤價,150);

  Var1A:=EMA(Var19,100);

  Var1B:=2*(Var19-Var1A);

  Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);

  Var1D:=SQRT(SQRT(最低價*最高價*開盤價*收盤價));

  Var1E:=EMA(Var1D*0.97,3);

  Var1F:=(最高價+最低價+收盤價)/3;

  Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));

  Var21:=CROSS(Var1E,最低價);

  買點1:=Var10;

  買點2:=(Var11+Var13+Var15+Var17);

  賣點1:=(Var12+Var14+Var16+Var18),linethick2;

  Var22:=買點1 AND VarF AND VarC AND Var21 AND Var4<0

  AND Var5=0 AND Var6=0 AND Var20<(-110);

  VAR1:=MA(收盤價,5);

  VAR2:=MA(收盤價,10);

  VAR31:=MA(收盤價,30);

  VARB1:=SUM(收盤價*成交量*100,28)/SUM(成交量*100,28);

  VARC1:=INTPART(VARB1*100)/100;

  VARD1:=EMA(收盤價,5)-EMA(收盤價,10);

  VARE1:=EMA(VARD1,9);

  VAR131:=REF(VARE1,1);

  VAR141:=VARE1;

  VAR151:=VAR141-VAR131;

  VAR161:=REF(VARD1,1);

  VAR171:=VARD1;

  VAR181:=VAR171-VAR161;

  VAR191:=開盤價;

  VAR1A1:=收盤價;

  DRAWTEXT(買點1>0,L-0.01,'▲'),colorred;

  DRAWTEXT(買點2>0,L-0.01,'▲'),COLORFF00FF;

  DRAWTEXT(賣點1>0,H+0.1,'▼'), COLOR33FF33;

  {務必向前復權使用,股價必須在站三條均線之上操作}

二肖中特wwwdooocc